Autor Tema: VIC-20 pantalla negra  (Leído 2172 veces)

mjj

VIC-20 pantalla negra
« en: Diciembre 12, 2018, 18:41:50 »
Buenas!!

Vengo de casa de un vecino de ver un VIC-20 de esos que "hace 10 años funcionaban perfectamente", y no he podido evitar comprarlo (tenía muy buen precio). Pero como era de esperar, no arranca. Creo que no hay señal de vídeo en absoluto. Es de los que llevan entrada DIN, así que lo he probado con una fuente de C64 que sé que funciona y con este cable de vídeo compuesto a la tele, que pone que vale para el VIC-20.

¿Alguna idea de cómo empezar?
 

rgrocha

  • Commodorero
  • **
  • Mensajes: 41
  • SYS 0
    • Ver Perfil
Re:VIC-20 pantalla negra
« Respuesta #1 en: Diciembre 12, 2018, 20:32:46 »
La pantalla negra pueden ser muchas cosas.

Entiendo que el led rojo se te enciende
 Si no mira el fusible.

Si se enciende prueba a apretar todos los chips que estén en zocalo.

Mas que eso, si no tienes unos conocimientos básicos de electrónica  (al menos soldar y desoldar chips) no puedes hacer nada.

Un saludo

Enviado desde mi SM-G850F mediante Tapatalk

 

mjj

Re:VIC-20 pantalla negra
« Respuesta #2 en: Diciembre 12, 2018, 20:52:55 »
Gracias! Sí, el LED enciende y el fusible está bien. Creo que me he precipitado antes diciendo que no hay señal de vídeo. Probando en otra TV se ve esto:



Y se queda así, fijo.

He probado a teclear a ciegas un programa que pokea en 36879 para cambiar los colores de borde y fondo y se notan cambios: el azul y el negro parpadean pero esencialmente siempre se ve negro y azul, por lo que deduzco que al menos el 6502, la RAM, la VIA del teclado, el BASIC y el KERNAL van así que me siento un poco más optimista.

He quitado los 3 condensadores electrolíticos de la jaula del VIC. Son japoneses (LUJAZO), concretamente de marca Unicon. Los he comprobado y están todos por encima de su capacidad nominal. Mi intención es recolocarlos donde estaban.

¿Algún componente más de la jaula que pueda comprobar?

Tengo un osciloscopio. En los pines del DIN de vídeo veo señal pero no tengo ni idea de qué voltajes debería tener ni qué buscar.
 

rgrocha

  • Commodorero
  • **
  • Mensajes: 41
  • SYS 0
    • Ver Perfil
Re:VIC-20 pantalla negra
« Respuesta #3 en: Diciembre 12, 2018, 21:02:46 »
Así si! :D :D

Prueba a girar los dos condensadores variables que tienes en la jaula.

Si tuvieras otro VIC prueba a cambiar el chip VIC (el grande de la jaula) a ver si lo soluciona.

Ya en detalle tienes la guía de Ray Carlsen para el VIC20 Txinto Vaz:
https://www.jotdown.es/2018/12/angel-alonso-en-planeta-imaginario-decidi-tratar-al-publico-infantil-con-exigencia-y-respeto/



Enviado desde mi SM-G850F mediante Tapatalk

 

marcos64

Re:VIC-20 pantalla negra
« Respuesta #4 en: Diciembre 12, 2018, 22:07:01 »
Eso es una TV moderna? Si fuera asi, primero prueba en una TV de tubo.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.
 

mjj

Re:VIC-20 pantalla negra
« Respuesta #5 en: Diciembre 12, 2018, 22:50:41 »
No tengo otro VIC para probar. Lo que sí tengo es una tele vieja de tubo, así que voy a probar eso lo primero. Las patas del VIC que entiendo lo que son (relojes y alimentación básicamente) parecen estar bien.

He probado a girar C48, veo que el reloj que sale por las patas 35 y 36 varía ligeramente entre 1.10820 y 1.10850 MHz pero no mejora el vídeo.

Lo otro que puedo ajustar creo que es un potenciómetro y parece que afecta a la ganancia de la señal de salida porque se va oscureciendo un poco la imagen pero tampoco soluciona el tema.

Ahora os cuento qué pasa con la tele de tubo.
 

mjj

Re:VIC-20 pantalla negra
« Respuesta #6 en: Diciembre 12, 2018, 23:10:20 »
Pues nada, con la tele vieja no se ve absolutamente nada, ni variando el potenciómetro/condensador variable.
 

marcos64

Re:VIC-20 pantalla negra
« Respuesta #7 en: Diciembre 13, 2018, 15:47:54 »
Mal asunto. Solo te queda ir probando paso a paso la guia de Ray Carlsen.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.
 

mjj

Re:VIC-20 pantalla negra
« Respuesta #8 en: Diciembre 13, 2018, 15:56:38 »
Resultado de probar con el modulador, el cable de antena y la tele de tubo (me lo han sugerido en lemon):



He visto que el circuito que va del VIC a la salida del conector DIN es más simple que un botijo: mezcla las señales de intensidad y color del VIC con un par de resistencias y condesadores (difícil que falle), y de ahí a un transistor que hace de buffer (y he comprobado que funciona). Mal asunto, me temo que sea el VIC y estos sí que son escasos :(
 

javierglez

Re:VIC-20 pantalla negra
« Respuesta #9 en: Diciembre 13, 2018, 17:56:20 »
En el foro de vic 20, que es sleepingelephant denial, un señor vendía 6561 a 20€ supongo que probados. Se ve que en China hay o algo.
 
Los siguientes usuarios dieron las gracias a este tema: mjj

mjj

Re:VIC-20 pantalla negra
« Respuesta #10 en: Diciembre 13, 2018, 19:35:09 »
Localizado y enviado PM... A ver si llego al fondo de este asunto.
 

mjj

Re:VIC-20 pantalla negra
« Respuesta #11 en: Diciembre 13, 2018, 23:27:13 »
Estoy esperando a que me conteste el vendedor de VICs de sleepingelephant (quién pone nombre a estos foros??), pero me está pudiendo el ansia viva y, como no he escarmentado después de comprar CIAs falsas en China, estoy pensando en comprar el VIC en Aliexpress (sí, en ALIEXPRESS).

Concretamente estoy viendo estos:

https://www.aliexpress.com/item/6561-101/32839077573.html

Tienen feedback positivo de 5 personas, 2 de las cuales comentan que funcionan bien y que han arreglado su VIC-20 con esos chips.

¿CÓMO PUEDE SER ESTO? ¿Es que hay almacenes en China con palés de chips de 1984 que nadie ha usado hasta ahora? ¿En 1984 China ya tenía potencia tecnológica para fabricar chips? Y si no, ¿cómo llega a manos de este vendedor chino semejante stock de chips? (pone que tiene 485).
 

javierglez

Re:VIC-20 pantalla negra
« Respuesta #12 en: Diciembre 14, 2018, 11:25:25 »
Porque antes debían reciclar los deshechos electrónicos en china y sí que debieron guardar los chips sí.
Yo de los vic1 de china no he encontrado ningún post que hable de falsificación. También debería pedirme uno.
 

mjj

Re:VIC-20 pantalla negra
« Respuesta #13 en: Diciembre 14, 2018, 13:33:58 »
Al final me la juego y me he pillado el 6561-101 de China. Pero del vendedor de los 5 feedbacks no porque tiene unos gastos de envío absurdos. Al final de éste, que solo tiene 1 feedback sin comentario pero es positivo:

https://www.aliexpress.com/item/1PCS-LOT-6561-101-DIP-40-new-and-original/32889537194.html

En dos semanas os cuento si me llega un VIC o una boñiga con patas.

Edito: le he preguntado al vendedor si son auténticos y me ha contestado:

"it`s new original".

Esto me servirá en caso de disputa si no lo son.
« última modificación: Diciembre 14, 2018, 13:45:04 por mjj »
 

marcos64

Re:VIC-20 pantalla negra
« Respuesta #14 en: Diciembre 14, 2018, 15:22:29 »
Commodore fabrico chips en Hong Kong asi que no seria extraño que en algun momento apareciera un lote de chips. Pero veo mas probable que sean chips reciclados.

Con esos comentarios me preocuparia mucho si luego resultaran ser falsos.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.