Autor Tema: Problema cargando el Beach Head 2 y no sé si otros...  (Leído 986 veces)

Naibor

Problema cargando el Beach Head 2 y no sé si otros...
« en: Octubre 21, 2018, 11:10:58 »
Hola, tengo un problema muy raro, mi C64 no carga el Beach Head 2, se queda en la pantalla inicial que pone "The saga continues..." y ahí se queda.

He probado unos 4 cracks diferentes, y hasta un CRT y en todos hace lo mismo.

Tengo otro C64 que carga perfectamente el juego en todas sus versiones, con lo cual entiendo que hay algún problema en mi C64.

Lo raro es que puedo cargar y jugar durante horas a todo lo que he probado hasta ahora, cargo demos largas hasta el final sin problemas.

Le he pasado el Dead Test y no me da ninguna pista.

No sé si este juego en concreto utiliza alguna característica especial que no funciona el mi C64 y por eso escribo este hilo.

Si tenéis idea de qué puede ser o por dónde puedo empezar a mirar, os agradecería mucho.

« última modificación: Octubre 21, 2018, 11:13:43 por Naibor »
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

mjj

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #1 en: Octubre 21, 2018, 14:43:35 »
Vistazo rápido con el C64Debugger... Esa pantalla usa un temporizador basado en el TOD (Time of Day) de la CIA1, así que puede ser la CIA1 o un chip que hay justo antes, U27 en placa larga / U23 en placa corta, un pequeño zener que hay cerca (en orden de más caro a más barato de reparar) o simplemente que no esté haciendo buen contacto la CIA si está en un zócalo. Prueba a reasentarla lo primero.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Naibor

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #2 en: Octubre 21, 2018, 17:59:49 »
Madre mía @mjj !!! eres el puñetero amo !!!

He cambiado las CIAs de sitio y ya funciona.

MUCHAS GRACIAS !!!

Supongo que la CIA1 no está muy allá pero por ahora funciona todo en la CIA2 así que por el momento lo dejo así.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

Naibor

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #3 en: Octubre 21, 2018, 20:53:27 »
Cuando le paso el CIADIAG me aparece un error en el PortB del CIA2

Parece que pone ERROR 85

El caso es que he probado los puertos de Joystick y van todos bien (los 4, ya que tengo el adaptador de 4 joys para el puerto usuario)

No sé en qué puede afectar este error, pero por ahora no he visto ningún fallo. Supongo que ya me enteraré, que empezará a fallar algo...
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

mjj

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #4 en: Octubre 21, 2018, 21:41:37 »
El portb de la cia2 controla el puerto usuario mientras que en la cia1 controla la matriz del teclado. Lo que me parece curioso es que las dos cias pasen el test TOD. Y más curioso es que el portb de la cia2 te dé error cuando esa cía antes controlaba el teclado ok... Así que a lo mejor el problema es solo de mugre/corrosión en los contactos.
 

Naibor

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #5 en: Octubre 22, 2018, 07:19:49 »
Probaré a sacar el chip y limpiarlo, peo me da miedo porque estos chips son muy delicados, se rompen con mirarlos, ya me cargué una CIA sólo limpiándola con un cepillo de dientes y limpia contactos.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

josepzin

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #6 en: Octubre 22, 2018, 12:16:33 »
se rompen con mirarlos, ya me cargué una CIA sólo limpiándola con un cepillo de dientes y limpia contactos.

¿Qué se te rompió? las patitas?
 

Naibor

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #7 en: Octubre 22, 2018, 12:33:23 »
No sencillamente dejó de funcionar la CIA después de frotar con el cepillo, no sé si pilló estática o algo así.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

mjj

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #8 en: Octubre 22, 2018, 12:41:09 »
Probaré a sacar el chip y limpiarlo, peo me da miedo porque estos chips son muy delicados, se rompen con mirarlos, ya me cargué una CIA sólo limpiándola con un cepillo de dientes y limpia contactos.

Se rompen porque no tienen protección contra la electricidad estática. Intenta no tocar las patas con los dedos pero como esto es muy difícil, descárgate antes tocando la toma de tierra de un enchufe y algo metálico del C64 a la vez (p.ej. la caja del modulador), así todo se queda al mismo potencial. Si tienes suelo de gres, manipula el chip descalzo y tocando el suelo con el pie. Si no tienes un suelo que conduzca la electricidad, te puedes comprar un guante de esos que te mantienen permanentemente al potencial de la tierra (para que sea efectivo debe ir conectado con una pinza a la toma de tierra de casa y haber descargado el C64 tocándolo con el guante, p.ej).
 
Los siguientes usuarios dieron las gracias a este tema: josepzin, Naibor

Jordi

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #9 en: Octubre 23, 2018, 22:48:49 »
Puedo corroborar que lo del pie en tierra funciona. Yo también uso unos guantes de tela que son antiestaticos. Suelen valer bien caros pero en Aliexpress los hay por dos euros.
 

Naibor

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #10 en: Octubre 25, 2018, 19:26:31 »
@mjj por favor me puedes decir si al C64 le vale el chip MOS 6526 A-1 ?

Es que hay uno en ebay pero dicen que va a 2mhz y ya me cabe la duda si le vale o no.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

mjj

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #11 en: Octubre 25, 2018, 20:55:07 »
Hasta donde yo sé el 6526A (2 MHz) es compatible con el 6526 (1 MHz). El "-1" no sé lo que es. Yo te diría que sí que va a funcionar, pero a ver si alguien más te confirma.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

marcos64

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #12 en: Octubre 25, 2018, 21:42:45 »
Hasta donde yo sé el 6526A (2 MHz) es compatible con el 6526 (1 MHz). El "-1" no sé lo que es. Yo te diría que sí que va a funcionar, pero a ver si alguien más te confirma.
Lo  mismo. El A (2MHz) funciona tambien, yo he tenido/tengo varios de esos funcionando. El -1 tampoco me suena de nada.

En principio, si es un 6526 de MOS te deberia funcionar.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Naibor

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #13 en: Octubre 25, 2018, 21:46:54 »
Muchas gracias por vuestras respuestas
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

Dany

Re:Problema cargando el Beach Head 2 y no sé si otros...
« Respuesta #14 en: Octubre 26, 2018, 21:39:51 »
pero por qué no cargas los CRT en la Ultimate 2 y te dejas de problemas? :)