Autor Tema: Pantalla negra, saco el VIC y lo vuelvo a poner y funciona  (Leído 5123 veces)

marcos64

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #30 en: Junio 18, 2018, 22:09:23 »
Perdona marcos64 no había entendido tu mensaje anterior al decir que midiera los 5V en el VIC.

No me había dado cuenta de que el VIC tenía 2 voltajes:

12V en el pin 13
5V en el pin 40

Qué cosas hacían en la época...

Muchas gracias de nuevo marcos64 a ver si saco tiempo y vuelvo a medir voltajes.

Por cierto, ¿qué es el 7805?

El SID tambien tiene los 2 voltajes.

El 7805 es el regulador https://en.wikipedia.org/wiki/78xx que crea los 5Vcc de los 9Vca que da la fuente (junto con otros componentes). Esta abajo a la derecha encima de un disipador de aluminio. Tambien se calienta bastante.
« última modificación: Junio 18, 2018, 22:11:58 por marcos64 »
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Angel_64

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #31 en: Junio 18, 2018, 22:27:51 »
Por cierto, ¿qué es el 7805?
Como dice @marcos64 , el 7805 es un integrado que el voltaje de salida será siempre de 5v constante y estable.
En la placa del C64 encontrarás un 7812 y un 7805. Cada uno dará su correspondiente voltaje estable segun sus 2 últimas cifras.
Te pongo una foto de los mismos antes de ser substituidos por unos nuevos.
A la izquierda el 7812 y a la derecha el 7805.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Naibor

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #32 en: Junio 18, 2018, 22:29:18 »
Y de las tres patas que tiene, cuáles debo de medir?

10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

Angel_64

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #33 en: Junio 18, 2018, 22:52:40 »
Y de las tres patas que tiene, cuáles debo de medir?
Cada regulador vale 50 centimos de euro... no vale la pena y por la edad que tienen, cambialos. Recuerda de poner un poco de pasta térmica en el de 5v, el del difusor.
De todas formas la pata izq es entrada de voltaje, la central GND y la derecha es la salida. Puedes comprobar con una fuente de alimentacion conectada a pata izq positivo, central neutra y el tester en pata central neutro y pata derecha positivo. Eso sí, la corriente de entrada un poco superior a 5v en continuo, unos 2v por encima. Si está bien te deberian dar los 5v de cc en salida. Pero ya te digo que por el precio no vale la pena y es mas seguro cambiarlos.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Angel_64

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #34 en: Junio 18, 2018, 23:44:05 »
Me picó la curiosidad y he comprobado el voltaje de salida de un 7805 desmontado hace poquito del C64 y los resultados son:
Para una fuente de entrada de 8'33v en cc me ha dado una salida de 5'02v cc bastante aceptable. El regulador estaba bien... pero no me la juego y lo cambié.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Naibor

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #35 en: Junio 19, 2018, 07:01:21 »
Muchas gracias por la información Angel_64, muy gráfico todo
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 
Los siguientes usuarios dieron las gracias a este tema: Angel_64

marcos64

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #36 en: Junio 19, 2018, 13:20:54 »
Siempre merece la pena comprobarlo para estar seguros, o no, de que da problemas. Y luego sustituirlo.

Se me olvido el 7812 a pesar de verlo en la foto, demasiado tiempo usando placas cortas...
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.
 

Naibor

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #37 en: Junio 21, 2018, 20:01:40 »
Acabo de medir voltajes y la verdad es que estoy desconcertado porque lo que he medido no sé si es correcto.

El 7805 mide 4,94v estables

Pero el 7812 mide

En la patilla 1 casi 20v !!! 19,8 ¿ ¡¡ Esto es correcto !! ?

En la patilla 3 11,98V
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

Angel_64

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #38 en: Junio 21, 2018, 20:10:47 »
El 7805 mide 4,94v estables
Pero el 7812 mide En la patilla 1 casi 20v !!! 19,8 ¿ ¡¡ Esto es correcto !! ?
En la patilla 3 11,98V
Lo importante es la salida. Por una parte te dan casi 5v y el otro casi 12v. Estan bien.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

marcos64

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #39 en: Junio 21, 2018, 22:00:03 »
Los 20V a la entrada del 7812 son algo elevados pero creo recordar que normales, al menos en mi 1541 tambien estaba por ahi.

De todas formas, para completar, comprueba tambien los 9Vca en el puerto del usuario.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Naibor

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #40 en: Junio 21, 2018, 22:23:09 »
Muchas gracias a ambos me quedo tranquilo.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

mjj

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #41 en: Junio 21, 2018, 22:44:58 »
Esos 20V son un poco bestias, debería ser algo más entre 14 y 16V. No es grave porque el máximo del 7805 y 7812 es bastante superior: unos 35V que varían según fabricante, pero tienes que tener en cuenta que los reguladores lineales como el 7805 y el 7812 funcionan convirtiendo el exceso de voltaje en calor. Por ejemplo, si el 7805 tiene que bajar esos 20V a 5V y por él circulan, p.ej. 0.2A (no sé cuánto circula por el 7805 interno del C64, así que lo digo a ojo), el exceso de voltaje es 15V y la potencia disipada será 15 * 0.2 (corriente * voltaje) = 3 W. Eso significa que tu 7805, aparte de cumplir su función reguladora de voltaje, se comporta como una pequeña estufita de 3 watios, que no parece mucho pero para un encapsulado tan pequeño sí que lo es. Tócalo a ver si quema mucho, aunque el 7805 puede aguantar temperaturas superiores a los 70º y la prueba de quemarse con el dedo tampoco es muy significativa.

De todas formas tampoco hay que ser fanático con la temperatura del 7812/05 porque en teoría tienen protección contra sobrecalentamiento (se desconectan), siempre y cuando sean de un fabricante con reputación, porque parece ser que hasta de los 78xx hay clones low cost.
« última modificación: Junio 21, 2018, 22:47:46 por mjj »
 
Los siguientes usuarios dieron las gracias a este tema: Naibor, Angel_64

Scooter

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #42 en: Junio 21, 2018, 23:02:46 »
El problema del 'se desconectan' es que efectivamente no se destruyen pero por ejemplo puede dejar loco al VIC porque le sigan llegando los 5 y no los 12 o viceversa. Cuando se enfrían vuelven a ir hasta que se calientan lo que puede generar un vaivén que te vuelva loco o acabé rompiendo algo.

Hay equivalentes pin a pin conmutados que no se calientan, pero no sé si meterían ruido eléctrico. Habría que probar.
Muchos usuarios de spectrum Cambian el 7805 por uno conmutado y les va bien.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor

Naibor

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #43 en: Junio 23, 2018, 09:14:03 »
La cosa ha empeorado.

Ayer compré un limpiador de contactos y fui sacando chip a chip, limpiando contactos y a los zócalos.

He debido de cargarme una CIA, porque en un principio arrancaba, pero no parpadeaba el cursor y estaba completamente bloqueado, sin teclado.

El Dead Test me daba error de teclado y timer.

El CIADiag ni arranca.

Saqué primero la CIA 1 (izquierda) la volví a limpiar y luego la CIA2 (derecha) e hice lo mismo.

Ahora arranca y parpadea. Tengo teclado y funcionan los 2 joys.

Pero el CIADiag sigue sin arrancar, y algunos juegos ni cargan.

Las dos CIAS son 6526.

¿Puedo intercambiarlas para saber si es un problema del chip o del zócalo?

¿Hay alguna prueba que pueda hacer para identificar cual es la que falla?

Gracias.

10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

mjj

Re:Pantalla negra, saco el VIC y lo vuelvo a poner y funciona
« Respuesta #44 en: Junio 23, 2018, 09:29:12 »
Ouch, qué putada!

La CIA U1 controla teclado, joysticks y cursor. La U2 el cassette, la diskettera y el puerto usuario. Con eso puedes diagnosticarlas. Por suerte aún son baratas en retroleum. A ver si tienes suerte y es mal contacto con el zócalo.

Son muy sensibles a las descargas electrostáticas, la protección que llevaban contra ellas es nula o muy inefectiva.
 
Los siguientes usuarios dieron las gracias a este tema: Naibor, Angel_64