Autor Tema: Hola amigos!  (Leído 660 veces)

Angel_64

Hola amigos!
« en: Marzo 13, 2018, 20:18:39 »
Saludos!, me llamo Ángel y en el 1984 rompí la hucha para comprar un C=64 con el que disfruté unos años de mi juventud jugando y programando!. Acabó olvidado en el garaje dando paso a nuevas tecnologías pero la añoranza ha hecho que lo recuperara estos últimos días viendo que ese viejo teclado no está olvidado gracias a Internet. Después de leer y ver vídeos sobre el tema he substituido condensadores y reguladores de tensión, testado CPU, en definitiva ponerlo a punto y hoy lo he conectado con los mismos nervios que la primera vez... pero me he desilusionado un poco viendo la imagen en el monitor. Sé que es reparable pero no sé el error que tiene. Me ayudáis ????? Primero: cómo inserto una imagen de la pantalla? Con el icono de insertar parece que no puedo. En definitiva sale pantalla y borde en negro (black screen!) y los simbolos de arroba y cuadrado continuamente llenando toda la pantalla!!!
Gracias !!
« última modificación: Marzo 13, 2018, 20:47:32 por Angel_64 »
 

josepzin

Re:Hola amigos!
« Respuesta #1 en: Marzo 13, 2018, 20:20:44 »
Bienvenido!! un commodorero de la vieja escuela :)

Hay una guía de errores, ahora te paso el enlace.
 
Los siguientes usuarios dieron las gracias a este tema: Angel_64

josepzin

Re:Hola amigos!
« Respuesta #2 en: Marzo 13, 2018, 20:21:08 »

Angel_64

Re:Hola amigos!
« Respuesta #3 en: Marzo 13, 2018, 20:32:03 »
Muchas gracias, lo he estado leyendo y también consultado en una web "The pictorial c64 fault guide" y no he acabado de afinar el problema... si pudiera saber cómo insertar una foto, os la pondría.
 

mjj

Re:Hola amigos!
« Respuesta #4 en: Marzo 13, 2018, 20:37:14 »
Mira a ver si de las 3 ROM (BASIC, KERNAL, CHAR) alguna se calienta más que otra.

Si tienes un juego en cartucho y arranca, el BASIC estaría frito.

También puedes descartar las 2 CIAs y el SID simplemente quitándolos, el ordenador puede arrancar sin esos 3 chips (no tendrías teclado ni cursor).

Por último quitaría la PLA y la RAM y las probaría fuera del C64. Yo me hice unos programas para probar las 3 ROMs, la PLA y la RAM con un Arduino, quizá te pueda servir: https://github.com/jamarju/c64_test_tools

A veces falla más de un chip. Yo resucité mi C64 este verano y tenía rotas la PLA y la CHARROM. SUERTE.
 

Angel_64

Re:Hola amigos!
« Respuesta #5 en: Marzo 13, 2018, 20:42:03 »
gracias!!!

Ahí teneis una foto de la pantalla!!!
« última modificación: Marzo 13, 2018, 20:48:18 por Angel_64 »
 

mjj

Re:Hola amigos!
« Respuesta #6 en: Marzo 13, 2018, 20:52:51 »
Olvida todo lo que te he dicho antes :D

Tu problema se parece mucho al de los multiplexores de esta guía (hacia la mitad de la página):

http://retro64.altervista.org/blog/commodore-64-repair-a-quick-guide-on-the-steps-required-to-fix-it/
 
Los siguientes usuarios dieron las gracias a este tema: Angel_64

Naibor

Re:Hola amigos!
« Respuesta #7 en: Marzo 13, 2018, 22:00:57 »
Bienvenido Angel_64 siempre es un placer tener a commodorianos nuevos por aquí.

El compañero mjj ya te ha dado pistas de cómo solucionar el problema, pero también puedes valorar comprar una placa sin SID por ebay, suele haberlas entre 35 y 45€ para la panera, ya que he visto que has puesto el modelo de placa en otro hilo.

Las placas de C64C rondan entre 25 y 35€ sin SID.

¿Qué periféricos tienes? ¿qué juegos tienes? ¿a qué edad te sacaste el carné de conducir?
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 

Angel_64

Re:Hola amigos!
« Respuesta #8 en: Marzo 13, 2018, 22:11:06 »
Bienvenido Angel_64 siempre es un placer tener a commodorianos nuevos por aquí.

El compañero mjj ya te ha dado pistas de cómo solucionar el problema, pero también puedes valorar comprar una placa sin SID por ebay, suele haberlas entre 35 y 45€ para la panera, ya que he visto que has puesto el modelo de placa en otro hilo.

Las placas de C64C rondan entre 25 y 35€ sin SID.

¿Qué periféricos tienes? ¿qué juegos tienes? ¿a qué edad te sacaste el carné de conducir?

Gracias Naibor!! sólo tengo la panera y fuente de alimentación. El Datasette lo perdí por el camino junto con los juegos. Si consigo revivirlo me plantearé los periféricos y los juegos!
 

Naibor

Re:Hola amigos!
« Respuesta #9 en: Marzo 13, 2018, 22:22:37 »
Bueno, tampoco es una gran pérdida, yo no uso el Datassette desde los 80, lo conecté hace un tiempo sólo para probar si seguían funcionando unas cintas de la época y lo volví a guardar en su caja.

Ahora hay verdaderas maravillas de dispositivos de carga y almacenamiento que emulan disketeras, datasettess , catuchos, y hasta impresoras y modems.

Y con respecto a los juegos tienes todo el catálogo de Commodore 64 en webs como gb64.com y csdb.dk y por supuesto en el IND http://ind.commodoremania.com/ donde puedes encontrar preservaciones de tus juegos favoritos.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ
 
Los siguientes usuarios dieron las gracias a este tema: Angel_64

Angel_64

Re:Hola amigos!
« Respuesta #10 en: Marzo 13, 2018, 22:29:06 »
Olvida todo lo que te he dicho antes :D

Tu problema se parece mucho al de los multiplexores de esta guía (hacia la mitad de la página):

http://retro64.altervista.org/blog/commodore-64-repair-a-quick-guide-on-the-steps-required-to-fix-it/

Cierto MJJ, puede ser ese problema ya que la secuencia de caracteres es muy similar. Lo miraré detenidamente. Muchas gracias.
 

Bieno

Re:Hola amigos!
« Respuesta #11 en: Marzo 14, 2018, 08:09:24 »
Buenas y bienvenido al foro. Espero que puedas solucionar el problema y poner a punto el 64 para participar y divertirte con él !!!!
 
Los siguientes usuarios dieron las gracias a este tema: Angel_64

Angel_64

Re:Hola amigos!
« Respuesta #12 en: Marzo 14, 2018, 12:25:04 »
Muchas gracias Bieno !