Autor Tema: SIDs que suenan bien en emulador y no en C64 real, ¿por qué?  (Leído 3815 veces)

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Hola, alguien sabe por qué algunos SIDs suenan bien en el emulador como "SidPlay2W" y en un C64 real suena como a "cascado" es decir con ruido.

Adjunto un SID de ejemplo, este en concreto está hecho para 2SIDs y contiene 3 pistas, cuando lo pongo en C64 real, la primera pista en la cual una melodía suena por un SID y otra suena por el otro SID, el sonido tiene mucho ruido.

Sin embargo las 2 melodías siguientes suenan bien (las 2 melodías siguientes son las que suenan en la primera melodía, pero cada una por un SID)

Quizás el señor @uctumi sepa el motivo.

Actualmente tengo la siguiente configuración:
C64C con SID 8580 por el canal derecho y SID 8580 emulado con U2+ por el canal izquierdo, ambos en la dirección de memoria D400.

Gracias

10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

uctumi

  • Desarrolladores
  • Commodorista
  • ******
  • Mensajes: 86
  • SYS 0
    • Ver Perfil
    • Uctumi website
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #1 en: Diciembre 19, 2017, 19:47:13 »
Hola, alguien sabe por qué algunos SIDs suenan bien en el emulador como "SidPlay2W" y en un C64 real suena como a "cascado" es decir con ruido.

Adjunto un SID de ejemplo, este en concreto está hecho para 2SIDs y contiene 3 pistas, cuando lo pongo en C64 real, la primera pista en la cual una melodía suena por un SID y otra suena por el otro SID, el sonido tiene mucho ruido.

Sin embargo las 2 melodías siguientes suenan bien (las 2 melodías siguientes son las que suenan en la primera melodía, pero cada una por un SID)

Quizás el señor @uctumi sepa el motivo.

Actualmente tengo la siguiente configuración:
C64C con SID 8580 por el canal derecho y SID 8580 emulado con U2+ por el canal izquierdo, ambos en la dirección de memoria D400.

Gracias

Este SID está hecho para SID 6581, tal vez sea por eso?

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #2 en: Diciembre 19, 2017, 19:52:57 »
Eso pensé, pero si emulo el 6581 en el U2+ sigue sonando con ruido el canal por el que emulo...
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

danytoon

  • Visitante
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #3 en: Diciembre 19, 2017, 20:03:01 »
Odio el 8580... no sé en que vídeo lo he dicho hace poco

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #4 en: Diciembre 19, 2017, 20:07:31 »
Odio el 8580... no sé en que vídeo lo he dicho hace poco

@Dany Quest si tienes la panera a mano ¿puedes probar el SID en el 6581 y decirme si lo escuchas bien por favor?.

Tengo la panera guardada en su caja y me da mucha pereza montarla ahora mismo.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #5 en: Diciembre 19, 2017, 22:22:06 »
Haciendo pruebas he visto lo que pasa, y es que las 2 melodías salen por los 2 SIDs al mismo tiempo, y por eso se acoplan y producen ese ruido.

Es decir, se supone que la melodía 1 debería de salir por un SID y la melodía 2 debería de salir por el otro SID, pero supongo que habrá que configurar el U2+ asignándole otra dirección de memoria para que "bifurque" el sonido entre los 2 SIDs.

He probado varias configuraciones pero no he dado con la tecla, será cuestión de seguir probando.

También puede ser que este tipo de SIDs sólo funcionen con hardware real, es decir con 2 SIDs reales, o bien que estén hechos  sólo para emulador... no estoy seguro.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

marcos64

  • Commodore Master
  • *****
  • Mensajes: 2840
    • Ver Perfil
    • http://marcos64.orgfree.com/
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #6 en: Diciembre 19, 2017, 22:24:18 »
Por si acaso deberias asegurarte de que ese SID funciona al 100%. Es relativamente comun que un SID falle parcialmente, por ejemplo uno de los filtros, y el resto funcione bien.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #7 en: Diciembre 19, 2017, 22:28:36 »
Gracias Marcos, podría ser, pero no creo porque suena todo de maravilla, incluso SIDs hechos para 2SID como el de Uctumi.

Sólo me pasa con algunos 2SID como este que he adjuntado en el post inicial y algunos otros de las mismas características, es decir 2SID

De todas formas si puedes probar el SID y postear el resultado te lo agradecería mucho.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #8 en: Diciembre 19, 2017, 22:29:57 »
¿Conoces alguna herramienta de testeo de SID? ya es por descartar.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

celiddoro

  • Lo mejón.
  • Desarrolladores
  • Commodore Master
  • ******
  • Mensajes: 337
  • Moderno vintage
    • Ver Perfil
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #9 en: Diciembre 19, 2017, 22:36:23 »
Suena roto también en un 6581

Dejo el videito:

https://twitter.com/celidora/status/943234786247806976
« última modificación: Diciembre 19, 2017, 22:42:58 por celiddoro »
Lo mejón

marcos64

  • Commodore Master
  • *****
  • Mensajes: 2840
    • Ver Perfil
    • http://marcos64.orgfree.com/
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #10 en: Diciembre 19, 2017, 22:43:44 »
Adjunto el que yo uso, Sencillo pero eficaz si tienes un poco de oido. Como curiosidad el VICE no parece superar la prueba, aunque lo tengo con la emulacion sencillita.

Idealmente deberias tener desconectados todos los extras que tengas, solo por si acaso.
http://marcos64.orgfree.com/
Actualizacion 22/4/2018: Actualizada Load'N'Run numero 5 con nuevos TAPs y PRGs.

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #11 en: Diciembre 20, 2017, 00:00:13 »
Suena roto también en un 6581

Dejo el videito:

https://twitter.com/celidora/status/943234786247806976

Muchas gracias celiddoro.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #12 en: Diciembre 20, 2017, 00:01:17 »
Adjunto el que yo uso, Sencillo pero eficaz si tienes un poco de oido. Como curiosidad el VICE no parece superar la prueba, aunque lo tengo con la emulacion sencillita.

Idealmente deberias tener desconectados todos los extras que tengas, solo por si acaso.

Muchas gracias marcos64
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ

danytoon

  • Visitante
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #13 en: Diciembre 20, 2017, 01:11:34 »
Suena roto también en un 6581

Dejo el videito:

https://twitter.com/celidora/status/943234786247806976

Er Celi te lo ha hecho al final ;)

Naibor

  • Commodore Master
  • *****
  • Mensajes: 1071
  • LOAD "*",8
    • Ver Perfil
    • Commodore 64 Full
Re:SIDs que suenan bien en emulador y no en C64 real, ¿por qué?
« Respuesta #14 en: Diciembre 20, 2017, 07:17:14 »
Gracias Dany, sí parece ser que este tipo de SIDs están hechos para una configuración específica.
10 PRINT "I LOVE COMMODORE 64"
20 GOTO 10

https://www.youtube.com/channel/UCmBlO_t5eKDtb7YiFAm9TNQ