Autor Tema: Dudas sobre SEUCK C-64  (Leído 1910 veces)

macarvajal

  • Commodorero
  • **
  • Mensajes: 35
  • SYS 0
    • Ver Perfil
Dudas sobre SEUCK C-64
« en: Abril 26, 2017, 19:45:57 »
Buenas,
estoy trasteando con el SEUCK para C-64, a ver si consigo aprender lo suficiente como para presentar algo digno a la SEUCK Compo y Olé. Tras leer la guía de Errazkin (http://makers.commodoremania.com/p/guia-seuck.html) y los artículos recopilados en SEUCK vault (http://seuckvault.co.uk/) no consigo encontrar la solución a un problema que me trae bastante mareado:

Estoy usando con el emulador VICE la versión de SEUCK disponible en la página Makers (SEUCK-E0_06784_02.zip). Cuando ejecuto un juego en "test", no suena el efecto sonoro de disparo hasta que le doy tres veces al botón. La cadencia se mantiene: tres pulsaciones, suena el disparo.
Lo curioso es que si grabo el juego como terminado ("Save Finished Game"), al cargarlo en el emulador el efecto de sonido si funciona correctamente.

¿A alguien le ha pasado esto? ¿Se os ocurre alguna explicación? He probado en dos PC diferentes, pero el resultado es el mismo. También lo he reproducido con las versiones 2.4 y 3.0 de VICE.

Muchas gracias por adelantado y un saludo!!


« última modificación: Abril 26, 2017, 19:47:39 por macarvajal »
Merece la pena luchar por los propios sueños. ¿Por qué pasarse la vida realizando los sueños de otro?

josepzin

  • Administrador
  • Commodore Master
  • *****
  • Mensajes: 10262
  • Commodoreador web
    • Ver Perfil
    • Mi blog
Re:Dudas sobre SEUCK C-64
« Respuesta #1 en: Abril 26, 2017, 21:41:03 »
Invoca a @Errazking el SEUCK Master :P

Errazking

  • Desarrolladores
  • Commodore Master
  • ******
  • Mensajes: 762
  • SYS 0
    • Ver Perfil
Re:Dudas sobre SEUCK C-64
« Respuesta #2 en: Abril 26, 2017, 21:56:09 »
Lo primero saludarte, luego agradecerte el interés en la Spanish Seuck compo y olé.y luego aplaudir tu iniciativa de ponerte en marcha.
Respecto a ese fallo. No eres la primera persona que me lo menciona.
Es así en Vice, en Ccs64, que es el que uso habitualmente no existe ese problema.
Sobre el motivo de este fallo,  ni idea.
Siento no ser de mayor ayuda.

macarvajal

  • Commodorero
  • **
  • Mensajes: 35
  • SYS 0
    • Ver Perfil
Re:Dudas sobre SEUCK C-64
« Respuesta #3 en: Abril 26, 2017, 22:30:42 »
Lo primero saludarte, luego agradecerte el interés en la Spanish Seuck compo y olé.y luego aplaudir tu iniciativa de ponerte en marcha.

Al contrario: gracias a ti por promover esa iniciativa. Espero que tenga buena acogida y se presenten muchos trabajos. ¡Y a ver si logro dar la talla con mi aportación!

Respecto a ese fallo. No eres la primera persona que me lo menciona.
Es así en Vice, en Ccs64, que es el que uso habitualmente no existe ese problema.
Sobre el motivo de este fallo,  ni idea.
Siento no ser de mayor ayuda.

Bien, pues con esto me resuelves totalmente el problema. Había llegado a pensar que fuera una característica del SEUCK, que en modo Test no fuera capaz de mantener la velocidad. También había pensado pasarlo al Commodore, pero no me hacía mucha gracia desarrollarlo así.
Probaré con el Ccs64 y os cuento si funciona.

Muchas gracias!




Merece la pena luchar por los propios sueños. ¿Por qué pasarse la vida realizando los sueños de otro?

macarvajal

  • Commodorero
  • **
  • Mensajes: 35
  • SYS 0
    • Ver Perfil
Re:Dudas sobre SEUCK C-64
« Respuesta #4 en: Abril 26, 2017, 22:42:33 »
Hola otra vez.
Confirmado: con el Ccs64 v3.9.2 no se manifiesta el problema.  :o
Se ve que hay algo en VICE que hace que se dé el problema con el sonido. Tal vez sea una cuestión de configuración, o a lo mejor se trata de un fallo de la emulación. En cualquier caso, parece que habrá que pasarse al Ccs64!

Gracias de nuevo y un saludo!!!
Merece la pena luchar por los propios sueños. ¿Por qué pasarse la vida realizando los sueños de otro?