Autor Tema: Commodore Amiga 500, el intento por revivirlo se va complicando...  (Leído 158 veces)

rub3n

  • Sinver
  • *
  • Mensajes: 1
  • SYS 0
    • Ver Perfil
¡Hola a todos!

Resulta que llegó a mis manos un 'ordenador antiguo' que no se sabía si iba o no iba. El ordenador antiguo era un Commodore Amiga 500 con su monitor 1084s y otros accesorios.


El caso es que empezó la cosa muy bien con el monitor, pues resistió el viaje y encendió a la primera. El vendedor me decía que tenía alguna avería porque se veía verde, y resulta que al final es un botón del propio monitor que activa o desactiva ese modo verde.
Al final el monitor duró 3 encendidos y el switch de encendido dijo que ya tenía bastante y que ya no bloqueaba más el encendido... Aquí ya ha un poco de odisea para buscar un switch nuevo.

Y lamentablemente el Amiga 500 no enciende, no da ninguna señal, no se encienden los leds y la fuente de alimentación entrega los valores que debe dar, al menos con el tester todo correcto.

No entiendo casi nada de electrónica, pero me gusta el tema y la abrí, visualmente no se veía ningún condensador inflado o con líquido derramado, lo único visual que había es la resistencia de arriba del Denise quemado. Luego me puse a medir continuidad a las cosas y todo da continuidad, los condensadores, resistencias... Por lo que entiendo, hay un corto en la placa.



Me dijeron que podían ser los chips, malos contactos o alguno defectuoso, me puse a quitar todos los que se pueden retirar sin desoldar, y con todos ellos fuera, y la resistencia quemada también fuera, continua el corto y todo da continuidad.

Y estoy ahora en un callejón sin salida, porque mi nivel de electrónica da para ver lo que es evidente o guiarme por alguna falla común y probar suerte si es eso, pero no más.

¿Alguien que controle sobre estas máquinas, me puede dar algún hilo del que tirar?

Se lo agradecería muchísimo, me hace mucha ilusión poder tener un Amiga 500 completo y funcionando. Soy tan optimista que llegué a este foro por Google viendo el caso de @i286ASM y empecé a ver cosas ahí y ya hasta he comprado una Gotek, porque sólo me venía un disket de los Lemmings y me temo que va a ser más sencillo para las pruebas y tal, tirar de ese aparato. También he comprado un GS8200 para pasar de RGB a VGA, sin limitaciones de hz, como pasa con los adaptadores.

A ver si por casualidad alguien tuviera alguna idea sobre falla común o cosas que siempre fallen y poder mirar primero ahí.

¡Mil gracias!

javierglez

  • Commodore Master
  • *****
  • Mensajes: 352
  • terminator not seen
    • Ver Perfil
Re:Commodore Amiga 500, el intento por revivirlo se va complicando...
« Respuesta #1 en: Agosto 30, 2022, 10:00:50 »
Puedes echar un ojo a los componentes conectados siguiendo la pista de la resistencia quemada, esos resistor pack, no sé. Te vendría bien un esquema del circuito de la placa. Ahí pone algo de video output, quizá el cortocircuito se produjese por ahí. No es muy habitual ver componentes quemados, dudo que sea un fallo en un chip. Pero vamos no es mi tema tampoco, estaría bien saber dónde vives y quizá alguien local pueda ayudar.

Un truco para el boton del monitor es fijarlo encendido o apagado metiendo y sacando un palillo de madera.

PacoBlog64

  • Commodore Master
  • *****
  • Mensajes: 315
  • INC $D020
    • Ver Perfil
    • PacoBlog64
Re:Commodore Amiga 500, el intento por revivirlo se va complicando...
« Respuesta #2 en: Agosto 30, 2022, 10:27:59 »
Buenas y bienvenido al foro. Al margen de mirar lo que te comenta @javierglez, yo de ti primero me aseguraría de que la fuente de alimentación funciona correctamente por si acaso. Aquí tienes una guía rápida de problemas del A500 y posibles soluciones, espero que te ayude: https://ia601207.us.archive.org/33/items/Amiga5002000TroubleShooter/Amiga%20500-2000%20Trouble-shooter.pdf

Respecto al botón del monitor, es una avería recurrente pero es relativamente fácil cambiarlo y aún se pueden encontrar a la venta en internet: https://www.ebay.co.uk/itm/194404533775?mkevt=1&mkcid=1&mkrid=710-53481-19255-0&campid=5338722076&customid=&toolid=10050

Por aquí también tengo un 10484S que también tiene el botón estropeado, aunque sí me deja encenderlo si le insisto, pero por desgracia tiene otra avería más gorda y está muerto (creo que algo del tubo). Ojalá puedas arreglarlo porque tiene una calidad de imagen realmente buena.

¡Suerte!
Commodoriano desde mis tiernos 7 añitos. ¿Quién necesita más de 1MHz, 64KB de RAM, 16 colores y 3 canales de sonido?

Dashiad

  • Commodoremaníaco
  • ****
  • Mensajes: 136
  • SYS 0
    • Ver Perfil
Re:Commodore Amiga 500, el intento por revivirlo se va complicando...
« Respuesta #3 en: Agosto 30, 2022, 13:19:15 »
No he tenido ocasión de comprobarlo, pero si he entendido bien en vídeos que he estado viendo, una forma de encontrar dónde hay un corto, es poner el multimetro en mostrar resistencia, e ir viendo la resistencia entre un punto que *no* deba ser tierra (por ejemplo, el pin de alimentación de cada chip), y tierra.
E ir buscando dónde esa resistencia es la mínima (que debería ser la resistencia propia de la traza).
Eso debería darte el pin que está más cerca del corto.