Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Mensajes - Dashiad

Páginas: [1]
1
Mercadillo / Re:Importacion de lote de discos 5.25 para C64
« en: Diciembre 03, 2018, 00:39:28 »
Una caja de 10 discos 3M que he recibido hace poco, pesa 238 gramos (pesado con mi balanza), y según la declaración del paquete, 0.23 Kg, asi que coincide.

Desgraciadamente, se equivocaron de tipo al enviarlo...Y no tengo ni un floppy para probar decentemente la unidad de disco que compré..
Así que, si al final los consigues...Ya tienes otro para hacer negocioss :-P
Los siguientes usuarios dieron las gracias a este tema: DrKucho

2
Si es la panera, mira si llegan y salen los voltajes correctos de los reguladores...Dicho de otra forma, en la patilla superior derecha del SID, qué voltaje ves cuando se queda la pantalla en negro?
Te lo digo porque a mi me daba pantalla en negro por el conector de alimentación, que estaba algo suelto..Y puede parecer que es un problema de poner o quitar un chip, y lo que ocurre es que el movimiento que le das a la placa al quitarlo y ponerlo sea lo que genere contacto o no.
Los siguientes usuarios dieron las gracias a este tema: Naibor

3
Esta fuente no es más que un transformador por un lado, y por otro, un puente de diodos con un 7805 para sacar los 5v.
Si cambias la fuente por una más moderna...Que yo sepa, dentro del c64 tienes, de nuevo, este mismo circuito, (rectificacion con diodos + un 7805) para (por un motivo que se me escapa), volver a sacar 5 voltios de la corriente alterna. Estos 5v, de acuerdo con los esquemas, alimentan, entre otras cosas, el VIC en los breadbin.
[Nota: es posible que la segunda conversión AC-DC, esté para evitar pedir más  de los 1.5A de corriente máxima del 7805 de la fuente?)

Si el problema de la fuente es por el epoxy, que no tiene aireación, y que algunas no se pueden arreglar, lo entiendo..Pero si es por motivos de diseño..aunque cambies la fuente, sigues teniendo el mismo problema dentro del c64 (entiendo que el amperaje que pasa por el 7805 interno es menor, y que se debería calentar menos, pero aun así..)

A donde voy es que, en mi opinion, si es posible hacer el mantenimiento de la fuente (que es bastante simple), o mejorarla en algo..a mi me gusta mantener la fuente original (y no es por "purismo"..al fin y al cabo, han "aguantado" 35 años..)

Ahora, si te toca el bloque de epoxy...ahi si que no hay mucho que hacer.
Los siguientes usuarios dieron las gracias a este tema: Angel_64

4
Soldando directamente a la placa los cables de la fuente de alimentación, el c64 funciona sin problemas.
Es el puñetero conector.
Lo malo es que no sé ahora cómo sustituirlo...Posiblemente me busque una pareja de macho/hembra, y me haga una fuente para este ordenador...Esto me permitirá seguir con el proyecto de integrarle la alimentación para una pantalla en el mismo conector.

La tercera placa, a la que no le iba el sonido, parece haberse arreglado simplemente ajustando un poco el SID en su socket...

Asi que ahora están las 3 funcionales...
Los siguientes usuarios dieron las gracias a este tema: josepzin

5
Creo poder confirmar que son los conectores de la fuente de alimentacion.Ambos.Los estoy probando desoldados de las placas,y , con ambos, hay una holgura que hace que la corriente por el pin de 9v, sea muy inestable.
El conector se compone de una serie de plaquitas planas.He intentado añadir una capa de estaño, sin mucho exito...
Los siguientes usuarios dieron las gracias a este tema: josepzin

6
@Maniako , muy posiblemente sea eso..Ayer vi que alguno de los pads de soldadura del conector, había desaparecido...Después, con las veces que soldé y desoldé el conector, algún otro también ha desaparecido..
Esta tarde probaré primero a usar cables desde las patas del conector, a los puntos más alejados posible (los 5V, de la pata del conector, a la pata del primer condensador, saltandome todo lo que pueda de la placa), para ver si con eso funciona.
Luego iré moviendo cables, uno a uno, de esos puntos alejados, al pad correspondiente del conector. Así, hasta que vuelva a fallar
Los siguientes usuarios dieron las gracias a este tema: Angel_64

7
He visto que el c64 se enciende si aplico una ligera torsion en el cable de alimentacion, a unos 7 cm del conector..
Cable de alimentacion mal? Probado con dos fuentes distintas.
Conector mal? Reemplazado el conector.Mismo problema.
Una mala soldadura? Habiendo reemplazado el conector, ese problema deberia haberse solucionado.

La torsion es tan minima que solo hace girar ligeramente el conector.Muy poca fuerza debe llegar a la placa...

Esto me esta volviendo loco....
Los siguientes usuarios dieron las gracias a este tema: josepzin

8
Despues de cambiarle los reguladores de voltaje, sustituir el D313 (Q1) ,y mover una de las CIAs...placa funcionando...aunque no se muy bien por que... 1 to go...
Los siguientes usuarios dieron las gracias a este tema: Naibor

9
Problemas Hardware y Software / Re:Estudio disipadores
« en: Mayo 07, 2018, 10:19:27 »
Según la datasheet, la temperatura de operación del SID es:

Operating Temperature, Ta 0° C to +70° C

O sea, que con el cartoncito, ya está por encima de la temperatura recomendada...
E incluso sin él, se queda a 4 graditos del límite, cosa que luego dependerá de que lo enciendas en agosto para echarte un head over heels en la terraza, o lo tengas en el refugio de montaña en navidades..

Visto lo visto...Yo me planteo directamente meter ventiladores...
Los siguientes usuarios dieron las gracias a este tema: Angel_64

10
Programación / Re:Colisiones sprite<>sprite por software
« en: Mayo 06, 2018, 14:07:20 »
Hay que tener en cuenta que en un juego como el que propone Maniako, tipo Arkanoid, si se hace por bounding box, la caja donde se metiera la bola deberia ser tan pequeña como la bola. Lo mismo para el pad. Si se utilizara una caja demasiado grande para cualquiera de los dos, quedaría muy inexacto.

Y, si es así, y simplemente se suman pixeles de movimiento, y se calculan colisiones, el problema es el mismo: la bola puede "saltarse" el pad.Y daría lo mismo que se haga por bounding boxes o por hardware, ya que las bounding boxes son pequeñas.
Por fuerza hay que interpolar la posición de la bola a la altura en la que se encuentra el pad, para ver si colisionaria o no.

En general, una cosa es la trayectoria que siguen los objetos, y otra es lo que se pinta en pantalla.Si cada punto de la trayectoria se va a pintar (cada uno de los pixeles), las interrupciones no deberian fallar nunca (otra cosa es que las bounding boxes deberian seguir usandose para saber qué sprites han colisionado entre si, si son más de dos).
Los siguientes usuarios dieron las gracias a este tema: josepzin

11
General / Re:Retromadrid 2018
« en: Abril 29, 2018, 18:22:38 »
...108.252:1986 ...
El neohabitat de las narices...
Los siguientes usuarios dieron las gracias a este tema: Bieno

12
General / Re:Retromadrid 2018
« en: Abril 03, 2018, 12:14:19 »
Dashiad, pues ya que te ofreces, a Bieno siempre le hacen falta manos para montar y desmontar...
Pues sin problemas...Yo puedo llevar algún C64 si hace falta, con algún cacharrejo..No es que tenga mucho que enseñar de hw, en todo caso, el sd2iec con arduino mega.
Los siguientes usuarios dieron las gracias a este tema: Bieno

13
General / Re:Emulación de disketera usando sólo arduino (mega)
« en: Enero 20, 2018, 23:51:24 »
Demo video del cacharro funcionando:

https://youtu.be/2Wsa2gebmeo

Los siguientes usuarios dieron las gracias a este tema: josepzin, Naibor

14
General / Emulación de disketera usando sólo arduino (mega)
« en: Enero 14, 2018, 23:54:31 »
Al fiiiinn...Después de muchos cabezazos, he conseguido cargar 1 juego usando sólo un arduino mega, con un lector de tarjetas SD!!!

Sí, sé que está el uno2iec, pero éste requiere del pc para enviar los d64.El arduino sólo se ocupa del protocolo serie.

Esto debería haber estado terminado el JULIO pasado, pero había algún error de timing que me estaba volviendo loco, y no lo conseguia encontrar. En medio de la transmisión, el c64 dejaba de dar ack de los bytes que le enviaba.
Hoy me ha dado por retomarlo...Y aunque la documentación indica que el tiempo que hay que mantener un bit activo para ser leído por el c64 es de 60us, hasta que no lo he subido a 80, no ha funcionado.


Aún no está para distribuirlo (el d64 a cargar está puesto a capón, el fichero a cargar, también, no se soporta ningún otro comando que "load" ), pero, al menos, algún juego arranca!!!

La idea es hacer que esté medio estable, y meter el código de pantalla táctil que hice para el tapuino.

Los siguientes usuarios dieron las gracias a este tema: migrator, PacoBlog64

15
General / Re:Mod: Joystick vtech vsmile para c64
« en: Mayo 05, 2017, 01:59:54 »
En la primera foto, dentro del cuadrado blanco, se ve que la placa tiene 7 "pads".El central, más grande, es el de reposo.
A cada lado del pad central, hay otros 3 pads (las 3 "sensibilidades")
Dentro del cuadrado blanco, a la izquierda, se ve una pieza blanca.El mando lo que mueve es esa pieza, hacia delante y hacia atrás.(en esa foto, el mando está al tope, para que se vea el pad).

La pieza blanca tiene una especie de horquilla metalica.Se ve (mal) en la esquina inferior derecha de la pieza, cómo hay 2 piezas metálicas finas, que están haciendo contacto con el pad más a la izquierda.En la segunda foto, la horquilla se ve mejor.
Al mover el mando en la dirección contraria, la pieza blanca se movería hacia la derecha, con lo que la horquilla haría contacto con cada uno de los otros pads.Es el mismo principio que un potenciómetro, pero en vez de ser un pad continuo, con resistencia, el pad no es continuo (tiene 7 partes).

En la segunda foto, se ve la horquilla que sale de la pieza blanca, estando el joystick en la posición "neutra" (el pad central).
Los siguientes usuarios dieron las gracias a este tema: josepzin

Páginas: [1]